19275 Posts in 3161 Topics - by 6136 Members - Latest Member: pango

Author Topic: Game crashing on launch  (Read 738 times)

Dadycupcakes

  • Newbie
  • *
  • Posts: 2
    • View Profile
Game crashing on launch
« on: April 15, 2017, 04:28:28 AM »
Avorion refuses to launch for me, when I launch it a black screen pops up for a second then the game crashes back to desktop. I'm running the latest version. The demo I downloaded from the Avorion site runs just fine but not the actual steam version for some reason. Any help would be much appreciated.

System Specs: AMD 9590, AMD RX 480, Windows 10

This is my client log:

2017-04-14 14-49-24| Client started: "D:\Steam\steamapps\common\Avorion\bin\Avorion.exe" "--serverpath=bin/AvorionServer.exe"
2017-04-14 14-49-24| Enabled Traces:
2017-04-14 14-49-24| Client Beta 0.11 r7857, running on Windows 8.1+.
2017-04-14 14-49-24| CPU: AuthenticAMD 8 Cores
2017-04-14 14-49-24| Init Steamworks...Installed Steam exception handler
2017-04-14 14-49-24| Init Steamworks... ok
2017-04-14 14-49-24| Init Steamworks ok
2017-04-14 14-49-24| Init SDL2... ok
2017-04-14 14-49-24| Getting display mode... ok
2017-04-14 14-49-24| Current display mode: 1920 x 1080
2017-04-14 14-49-24| Creating settings... loading... setting language... ok
2017-04-14 14-49-24| Creating client window...Creating borderless window
2017-04-14 14-49-24| Detected 1 displays
2017-04-14 14-49-24| Display 0: x: 0, y: 0, w: 1920, h: 1080
2017-04-14 14-49-24| Using display 0
2017-04-14 14-49-24| Creating window, x: 0, y: 0, w: 1920, h: 1080... ok
2017-04-14 14-49-25| GetDrawableSize: 1920 1080
2017-04-14 14-49-25| GetWindowSize: 1920 1080
2017-04-14 14-49-25| Creating GL context... ok
2017-04-14 14-49-25| Setting window mode WindowedSeamless... ok
2017-04-14 14-49-25| Creating client window ok
2017-04-14 14-49-25| Init rendering... starting rendering... initialize...OpenGL Context Information:
2017-04-14 14-49-25| Version: 4.5
2017-04-14 14-49-25| VersionString: 4.5.13474 Compatibility Profile/Debug Context 22.19.156.1
2017-04-14 14-49-25| Vendor: ATI Technologies Inc.
2017-04-14 14-49-25| Renderer: Radeon (TM) RX 480 Graphics
2017-04-14 14-49-25| GLSL Version: 4.50
2017-04-14 14-49-25| GL_MAX_VERTEX_UNIFORM_COMPONENTS: 16384
2017-04-14 14-49-25| GL_MAX_VERTEX_UNIFORM_VECTORS: 4096
2017-04-14 14-49-25| GL_MAX_CUBE_MAP_TEXTURE_SIZE: 16384
2017-04-14 14-49-25| GL_MAX_ELEMENTS_INDICES: 2147483647
2017-04-14 14-49-25| GL_MAX_ELEMENTS_VERTICES: 2147483647
2017-04-14 14-49-25| GL_MAX_RENDERBUFFER_SIZE: 16384
2017-04-14 14-49-25| GL_MAX_TEXTURE_SIZE: 16384
2017-04-14 14-49-25| GL_MAX_VERTEX_ATTRIBS: 29
2017-04-14 14-49-25| GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS: 32
2017-04-14 14-49-25| Init GLEW... ok
2017-04-14 14-49-25| Init Debug Message Callback... ok
2017-04-14 14-49-25| Set VSync... ok
2017-04-14 14-49-25| Secure BackBuffer... ok
2017-04-14 14-49-25| Init Canvas...Create canvas of size 1920 x 1080... ok
2017-04-14 14-49-25| Init Canvas ok
2017-04-14 14-49-25| Init Refraction Texture... ok
2017-04-14 14-49-25| Init Post Processing... ok
2017-04-14 14-49-25| Init Debug Renderers... ok
2017-04-14 14-49-25| DepthTexturesSupported: yes
2017-04-14 14-49-25| IntVertexAttributesSupported: yes
2017-04-14 14-49-25| DeferredSupported: yes
2017-04-14 14-49-25| LowSpecGPUDetected: no
2017-04-14 14-49-25| Rendering initialized
2017-04-14 14-49-25| Init rendering ok
2017-04-14 14-49-25| Check problematic drivers... ok
2017-04-14 14-49-25| Init shader level... ok
2017-04-14 14-49-25| Init loading screen... ok
2017-04-14 14-49-25| Draw first loading screen... draw...Error: EXCEPTION_ACCESS_VIOLATION
2017-04-14 14-49-26| [1] ?? 55619069
2017-04-14 14-49-26| [2] ?? 486607565
2017-04-14 14-49-26| [3] ?? 140722512920757
2017-04-14 14-49-26| [4] SwapBuffers 140722772655790
2017-04-14 14-49-26| [5] ?? 10349982
2017-04-14 14-49-26| [6] ?? 4241869
2017-04-14 14-49-26| [7] ?? 4208482
2017-04-14 14-49-26| [8] Mix_SetPanning 17072207
2017-04-14 14-49-26| [9] ?? 4199416
2017-04-14 14-49-26| [10] ?? 4199659
2017-04-14 14-49-26| [11] BaseThreadInitThunk 140722806621028
2017-04-14 14-49-26|

and that's where it ends.



DYtheDON

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Game crashing on launch
« Reply #1 on: April 15, 2017, 08:19:05 PM »
Same issue verbatim. I can run the Demo completely fine. It's literally some kind of issue regarding Steam/Avorion as the demo can launch instantly without issue.

thedamngod

  • Moderator
  • Sr. Member
  • *****
  • Posts: 390
  • Who is this guy anyway?
    • View Profile
Re: Game crashing on launch
« Reply #2 on: April 15, 2017, 09:27:16 PM »
There have been a lot of changes between the last demo and the current version. So it is not very surprising that the demo works for you.

The only thing I could suggest as a fix are the usual ones:
1. Try updating your graphics card drivers
2. Try to verify the game files using steam (unlikely to fix it imo)

If these won't work you will probably have to wait for a new patch from the devs :/
FAQ    Infos for bug reports

Want a post moved, locked, deleted? Think something is wrong or not appropriate? Then use the "Report to moderator" button

DYtheDON

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Game crashing on launch
« Reply #3 on: April 16, 2017, 12:54:24 AM »
Yah I have updated every driver I could think of, reinstalled the game at least 50-100 times, verified countless times, got a friend to send me his game files to test if something was missing, tried anything and everything I could find within the Steam Forums and Avorion Forums.  Was super excited to play this game but after 3+ hours of messing around I'm really starting to lose interest.

Keklily

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Game crashing on launch
« Reply #4 on: April 20, 2017, 12:52:22 PM »
This http://steamcommunity.com/app/445220/discussions/3/135514231766321066/ where Koonschi says

Quote
This looks like a crash in some windows binaries (ACCESS VIOLATION within DllMain etc). I don't have a solution for this right now, but my best guess is that the windows update broke some binaries.

Hammelpilaw

  • Newbie
  • *
  • Posts: 27
    • View Profile
Re: Game crashing on launch
« Reply #5 on: May 28, 2017, 11:45:31 AM »
I got an almost similar problem. When i logged in on the server i'm playing currently the game crashes. When i logged in on a offline galaxy a new player was created

Code: [Select]
2017-05-28 09-38-39| Error: EXCEPTION_ACCESS_VIOLATION
2017-05-28 09-38-40| [1] ?? 8233192
2017-05-28 09-38-40| [2] ?? 6268512
2017-05-28 09-38-40| [3] ?? 8717696
2017-05-28 09-38-40| [4] ?? 4969594
2017-05-28 09-38-40| [5] ?? 8714330
2017-05-28 09-38-40| [6] ?? 8717869
2017-05-28 09-38-40| [7] ?? 4946058
2017-05-28 09-38-40| [8] ?? 4959698
2017-05-28 09-38-40| [9] ?? 4227440
2017-05-28 09-38-40| [10] ?? 4231473
2017-05-28 09-38-40| [11] ?? 4208494
2017-05-28 09-38-40| [12] Mix_SetPanning 17072207
2017-05-28 09-38-40| [13] ?? 4199416
2017-05-28 09-38-40| [14] ?? 4199659
2017-05-28 09-38-40| [15] BaseThreadInitThunk 2004638141
2017-05-28 09-38-40|

I fixed that by deleting the settings files client.ini and settings.ini.