21295 Posts in 3605 Topics - by 7505 Members - Latest Member: Phox

Author Topic: Game stuck on 'Starting Sinlgleplayer' loading screen  (Read 208 times)

ninjastryk

  • Newbie
  • *
  • Posts: 2
    • View Profile
Game stuck on 'Starting Sinlgleplayer' loading screen
« on: September 20, 2017, 01:12:55 AM »
***Can a Mod please move this to Troubleshooting?  Posted in Bugs by mistake***

Hi, I'm unable to get past the loading screen when I try loading a game or starting a new one.  I was able to play without issues on this very same machine about 9 months ago when I was playing for about 70+ hours.  Game just sits at 'Starting Singleplayer' screen and never shows me the 'press space bar to continue' option and I have also tried turning that option off.  When I press 'Alt+F4' the game says 'Saving Galaxy' and I am able to attempt loading that saved galaxy but the game still hangs at the 'Starting Singleplayer' screen.  I have also tried the beta and it does the same thing.  I tried uninstalling(deleting 'Avorion' folder in %AppData% also) and reinstalling.

All other fixes that I searched the internet for over the past 2 days have not helped.

Thank you for your time.

Win 7 64 Ultimate
i7-5930k
GTX 1080ti

https://pastebin.com/fRhrinyK
« Last Edit: September 20, 2017, 01:16:51 AM by ninjastryk »

unbekannt1984

  • Jr. Member
  • **
  • Posts: 59
    • View Profile
Re: Game stuck on 'Starting Sinlgleplayer' loading screen
« Reply #1 on: September 20, 2017, 11:33:49 AM »
Hi,

I had a quick look at the log:
Quote
2017-09-19 18-02-39| Polling server at 127.0.0.1:27003
2017-09-19 18-02-39| Client UDP: Send packet to 127.0.0.1, port: 27003, size: 1024
You've got hundreds or thousands of these messages, they mean that the game-client is waiting for the built-in server to get ready and connect to it.

So, there are a few possibilities:
a) Your firewall doesn't allow Avorion to connect to the server (through what one would call the loopback-device on Linux),
b) same as a), but it doesn't allow the server to communicate with the client and
c) your server doesn't work (easy to check, try to connect to a different server - well, one without MODs).

Additionally to checking your firewall and trying to connect to a server, you should try to find and upload the server-log, too. I just saw that you uploaded it, too. I'll have a look at it.

I hope this helps you a little :)

EDIT: After looking at the server-log:
Quote
2017-09-19 18-00-02| Server UDP: Error receiving from 127.0.0.1, error: An existing connection was forcibly closed by the remote host, received bytes: 0

Yes, it's your firewall. If you didn't install a firewall yourself, you are using the one that M$ ships with Windows - and that one is weird :)

If you are unable to configure the M$-Firewall, get something better, for example http://www.zonealarm.com/software/free-firewall/ or switch to Linux :P (how about: https://www.debian.org/? - Just kidding :) )
« Last Edit: September 20, 2017, 11:44:21 AM by unbekannt1984 »

ninjastryk

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Game stuck on 'Starting Sinlgleplayer' loading screen
« Reply #2 on: September 20, 2017, 10:29:44 PM »
Hi,

I had a quick look at the log:
Quote
2017-09-19 18-02-39| Polling server at 127.0.0.1:27003
2017-09-19 18-02-39| Client UDP: Send packet to 127.0.0.1, port: 27003, size: 1024
You've got hundreds or thousands of these messages, they mean that the game-client is waiting for the built-in server to get ready and connect to it....


Thanks for the response.  Looking at this first observation of yours I was poking around in C:\Program Files (x86)\Steam\steamapps\common\Avorion and clicked on both 'client.bat' and 'server.bat' and sure enough, the next time I tried to load the game it finally loaded a game successfully!  Now the game loads just fine each and every time simply by launching from Steam.
« Last Edit: September 20, 2017, 10:31:41 PM by ninjastryk »