26020 Posts in 4383 Topics - by 9603 Members - Latest Member: Six2K

Author Topic: Player owned shipyard templates missing  (Read 976 times)

Clocked

  • Newbie
  • *
  • Posts: 4
    • View Profile
Player owned shipyard templates missing
« on: November 13, 2017, 12:28:06 AM »
 Hello all, super excited for this new economy update, I delved right in on a multiplayer server.

 So I created a shipyard in my own little sector, made sure it had everything needed, crewed it up all that good stuff
 and run into a big problem, there are no ship templates available, therefor I cannot create anything with the shipyard, if I click single block that will show up but it will not let me create even a single block.

I switched over to single player creative to see what happens, when I do that the player made shipyard has only 1 template Test something, that is all.

So for right now the player owned shipyards are useless :(

koonschi

  • Developer
  • Hero Member
  • *
  • Posts: 1471
    • View Profile
    • Avorion
Re: Player owned shipyard templates missing
« Reply #1 on: November 13, 2017, 11:40:44 AM »
Oh, that's definitely an unfortunate oversight, thanks for reporting!
#define TRUE FALSE // happy debugging suckers

If you need help, please post in the forum, don't PM me. If there's something that only I can help you with, contact me via mail.

Ragner

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Player owned shipyard templates missing
« Reply #2 on: November 20, 2017, 11:16:29 PM »
Hi,

if there a fixed for the player owned shipyard or still open?

thanks for the feedback

Phantomal

  • Newbie
  • *
  • Posts: 16
  • Andre Lanvermann
    • View Profile
    • Lanvermann
Re: Player owned shipyard templates missing
« Reply #3 on: December 29, 2017, 03:03:45 PM »
I just tried it in a single player game. You get a "TestStyle" and can create a working Ship now. Will test this on our server soon. But i assume it works the same.

stlblues05

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Player owned shipyard templates missing
« Reply #4 on: January 13, 2018, 03:28:34 AM »
I just ran into this same issue...

I am running a dedicated server for me and a friend, but every time we build an alliance shipyard we cant make any ships.  There are no templates to use.

It seemed like it was working earlier but now we are on the 3rd or 4th try and they still arent working. 

Edit:

I actually just noticed the cmd prompt shows an error for this.  I have attached a screenshot.
« Last Edit: January 13, 2018, 03:32:03 AM by stlblues05 »

Hammelpilaw

  • Sr. Member
  • ****
  • Posts: 370
    • View Profile
    • Scrap Yard - Avofactory
Re: Player owned shipyard templates missing
« Reply #5 on: January 13, 2018, 08:24:47 AM »
This issue sometimes happens on shipyards. I can not say for sure how to reproduce... Maybe it is related to duplicated ship names...
Restarting the server will fix it.

Kelven

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Player owned shipyard templates missing
« Reply #6 on: January 18, 2018, 03:27:03 AM »
Having this issue as well on our server. We tried to sift through the .lua files to see if we could figure out why. Best we could guess is since it's a player station and not an AI faction, it doesn't have a craftstyle associated with it. Was hoping to figure out how to hack that in somewhere so it uses that TestStyle that appears in singleplayer, but we're nowhere near competent enough to figure out how.

This issue sometimes happens on shipyards. I can not say for sure how to reproduce... Maybe it is related to duplicated ship names...
Restarting the server will fix it.

Restarting multiple times did not fix the issue.