Author Topic: Multi-player Server  (Read 3535 times)

Never7Dice

  • Newbie
  • *
  • Status:
    Offline
    Posts:
    3
    • View Profile
on: May 25, 2013, 12:58:43 PM
I already read this http://www.avorion.net/forum/index.php?topic=11.0

And i have problem with local and dedicated server.
I tried to open port.
And use CMD command.
But i still have problem "connection 0 by promote"



koonschi

  • Developer
  • *
  • Status:
    Offline
    Posts:
    1609
    • View Profile
    • Avorion
on: May 25, 2013, 01:22:19 PM
Do you get the same error when you start a singleplayer game?

In your %appdata%\Avorion folder there should be a serverlog.txt file. Can you post the file on the forum?
#define TRUE FALSE // happy debugging suckers

If you need help, please post in the forum, don't PM me. If there's something that only I can help you with, contact me via mail.



Never7Dice

  • Newbie
  • *
  • Status:
    Offline
    Posts:
    3
    • View Profile
on: May 25, 2013, 01:34:43 PM
Oh suddenly local server started and when my friend join writing connection closed 2 by promote and he is connecting. But dedicated server is not working. And we are playing with tunngle cause other ways doesnt work.



koonschi

  • Developer
  • *
  • Status:
    Offline
    Posts:
    1609
    • View Profile
    • Avorion
on: May 25, 2013, 01:39:26 PM
The "connection X closed" is not a bad thing, but it might be misleading. For now a client first looks whether a server is running, thus connects to it once to see if it is there. That's what causes this weird error message.
If you want, you can start a dedicated server again and then give me your serverlog. This way I can see what went wrong and fix it in later versions.
#define TRUE FALSE // happy debugging suckers

If you need help, please post in the forum, don't PM me. If there's something that only I can help you with, contact me via mail.