Author Topic: [0.16.5] Desync between graphic pipeline and ship block structure  (Read 815 times)

[DM]Origin

  • Newbie
  • *
  • Status:
    Offline
    Posts:
    10
    • View Profile
Ok. The Bug Report function ingame has a bug. It didn't upload the selected and well set client log file. Instead it breaks a message: "Please upload the client log". Well, I have done that. Therefore here:

Beta 0.16.5 r11107 d869ab146e13
Graphic Error
Main Game (Steam)

Description:
This happens in build mode with ships with a hight amount of blocks. It's about 30,000 blocks and more. At some point when blocks are deleted, the blocks are removed from the block structure, but remain in the graphic pipeline. The removed blocks are rendered but cannot be selected anymore. Instead the blocks behind them are selected. You need to relogin into to galaxy to fix that problem.

I toke a screenshot that show you the problem. All the glasses above the ship have been erased. See link below.
https://drive.google.com/file/d/1qDAfSRFGmsCbBNMUDMcFwKDpUBIMpiVT/view?usp=sharing

Steps to reproduce
This is difficult, because this bug ist random. Build a ship with over 30,000 blocks. Then start to delete blocks. And hope, this bug comes up.

Client and Server Logs
Are part of the zip file.



cepheni

  • Developer
  • *
  • Status:
    Offline
    Posts:
    348
    • View Profile
Thank you for reporting. This is a known bug that is tied to server performance. Ships with a lot of blocks generate lag because of the complicated physical calculations.

We are constantly improving on that, the latest update should have made it better already. This is issue will still be happening, but at least only with larger number of blocks than before.