Author Topic: [MP] Turret groupings changing  (Read 1946 times)

joemorin73

  • Newbie
  • *
  • Status:
    Offline
    Posts:
    10
    • View Profile
on: February 22, 2018, 03:21:18 PM
When reconnecting to a server, a ships turret group settings will occasionally change to a random configuration.  They seem to spread across 1, 5 and 7.  (I never use 5 or 7.)



joemorin73

  • Newbie
  • *
  • Status:
    Offline
    Posts:
    10
    • View Profile
on: February 23, 2018, 12:21:57 AM
Sorry, this should be in the Beta branch



Buffo

  • Newbie
  • *
  • Status:
    Offline
    Posts:
    4
    • View Profile
on: February 23, 2018, 12:57:38 PM
I've experienced this as well, but only in a 2-player multiplayer game.  It happened to my buddy first, and he honestly thought he had just made some crazy error right before closing the game the previous day.  But then it happened again, this time to both of us, and since I *never* use group 7 I knew something was wrong. 

Guess I'll file a bug report if it happens again, although I don't know how to reproduce it.  It seems to happen at random.



ohartenstein23

  • Newbie
  • *
  • Status:
    Offline
    Posts:
    5
    • View Profile
on: February 23, 2018, 01:57:21 PM
I've run into this too on a server, happens to me sometimes on exiting+entering a ship or switching between alliance ships as well as relogging. It seems to group independent targeting turrets separate from other turrets, as if this were an auto-grouping function.



schattensonner

  • Newbie
  • *
  • Status:
    Offline
    Posts:
    2
    • View Profile
on: February 24, 2018, 07:29:46 PM
Also happens on Singleplayer.

Groups 1,2 and 7 (all other Groups were unused) got renumbered/changed:
1 to 7, 2 to 5 and all turrets from the former group 7 got unassigned.


edit:
This happened after jumping to another System
I only use turrets with independent targeting
/
Again, after loading into my SP-save -> All Antifighter-Turrets were set to 5, PD-turrets to 6 and all others to 7
« Last Edit: February 25, 2018, 06:37:47 AM by schattensonner »



Ravien

  • Sr. Member
  • ****
  • Status:
    Offline
    Posts:
    255
    • View Profile
on: February 25, 2018, 07:43:35 AM
Had this happen a lot when using the "change sector" command to jump between my ships in different sectors.



DoorsMonster

  • Newbie
  • *
  • Status:
    Offline
    Posts:
    47
    • View Profile
on: February 26, 2018, 02:48:42 AM
I'm playing in a single player galaxy,  on 16.1 and I'm having the same issue after switching between sectors. Also all my fighters dissapeared and all my torpeados have gone. XD
OUCH. Is anybody else losing fighters/torpeados?



NoSvOrAx

  • Newbie
  • *
  • Status:
    Offline
    Posts:
    9
    • View Profile
on: February 26, 2018, 09:55:31 PM
The reassignment wouldn't be so bad, but it also changes the fire mode.  For the PDCs that were set to defend, why doesn't autofire work the same, they get set to mouse mode and the ship stops protecting itself.



Gantradies

  • Newbie
  • *
  • Status:
    Offline
    Posts:
    24
    • View Profile
on: April 19, 2018, 05:55:37 AM
i can confirm this still appears to be an issue in multiplayer- it isnt scrambling my groups,but it is making a mess of their settings whenever i log      outta my server :(



cepheni

  • Developer
  • *
  • Status:
    Offline
    Posts:
    349
    • View Profile
on: April 20, 2018, 11:26:45 AM
@Gantradies: Do you mean the independent fire mode? That is reset on each log out. As I said  in a different thread I will talk with our team about keeping the turret status over logoff. Before the torpedoes it was intentional, but I was convinced that with the torpedoes it is too dangerous to not remember the settings.