Author Topic: [Mod Info] Which Mods Are Supported This Patch? [0.17.1] [Beta 0.18]  (Read 4588 times)

Shrooblord

  • Hero Member
  • *****
  • Status:
    Offline
    Posts:
    523
    • View Profile
Hi one and all!

I'm an enormous fan of Avorion and love creating a better experience for myself and friends in-game with mods, and by modding the game myself. However, whenever an update rolls around, it's always quite a fuss to determine what parts of which code and scripts have changed, how that will affect my installed mods, and, more importantly, how to reinstall all the mods I've effectively "lost" by updating my scripts folder when patching.

To this extent, a mod manager would be ideal, but where such a tool does not exist for us (yet), I think the next best thing would be to compile a list of mods that we know are stable in this patch, to avoid headaches when patching up to the new version of the game, or the new beta version on the Beta Branch. This way, we can consult this one thread and find out which mods can be simply reinstalled, and which ones will need some more development / need to be patched before they become available to us again.

Now, I do not have all the time in the world and I would love for you guys to help me set this up to - a community effort, if you will.

That said, let's compile our shortlist of supported mods right now!


[0.17.1] STABLE MODS
These mods are stable on the latest patch of the base game. Simply install them and play!




[BB 0.18] STABLE MODS
These mods are stable on the latest patch of the beta branch. Simply install them and play!



STABILITY UNDER REVIEW
We are currently testing these mods in our games on the current patches. Preliminary testing results seem good so far (no crash on startup, game is playable). More interactions / test cases need to be explored still to bump this up to Stable.



STABILITY UNKNOWN
We haven't tested yet whether these mods work under the current patches. We need to investigate further into these.




DEPRECATED
These mods are confirmed no longer stable on the current patches. Mod developer action is required to conform to the changes introduced to the game since the last time the mod was stable. For each mod, the last known stable patch is mentioned.
  • Carrier Command - by Laserzwei -- crashes when used in multiplayer --  last known version compatible: [0.16.0]
  • Loot Collection for Carrier Command - by Padwan -- being a plugin of Carrier Command, this is unstable by extension of CC being unstable
  • out of sector Production - by Laserzwei -- all functionality provided by this mod is now vanilla behaviour! -- last known version compatible: [0.16.0]
  • CompleX3s - by Laserzwei -- deprecated by author (undergoing rework?) -- last known version compatible: [0.15.x]




To flesh out this list, we need to collect a list of all the mods for the game, put them in the "stability unknown" category, and systematically test them on the new patches.

Here's to making all our lives easier!

Thanks for your assistance,


Shrooblord


P.S.
I'm just running down the list of mods I find in the Mods forum as sorted by last posting activity - got to page 6 - will continue to run through all the mods posted in this subforum at a later time. If you know a mod you love that isn't included in this list, don't hesitate to post!


P.P.S.
At the time of writing this post there's 27 pages worth of mods in this subforum. Indiscriminately and systematically going through all of them will take some time. This is why the "Stability Unknown" section is so huge right now compared to the other categories. If you know anything about the mods in that section, please let us know in a post down below!


P.P.P.S.
I will be looking into sanitising this list later (i.e. ordering it alphabetically, most likely). Right now it's simply based on the order the mods appeared in as I'm browsing the Mods forum.
« Last Edit: July 26, 2018, 02:21:19 AM by Shrooblord »
Shrooblord



Kampfkrapfn

  • Jr. Member
  • **
  • Status:
    Offline
    Posts:
    68
    • View Profile
Great idea, Shrooblord !


For your list: I'm running these mods under 17.1, and do not experience any issues:
CarrierCommander
LootCommand for Carrier Commander
Compass-like Gate Icons
Detailed Turret Tooltips
MoveUI

Following mods are working well, but there seems to be an issue when both are active
Regenerative Asteroid Fields
Yet Another Mine



Laserzwei

  • Sr. Member
  • ****
  • Status:
    Offline
    Posts:
    351
    • View Profile
is technically not compatible with either 0.17 and 0.18 since in both multiplayer-crashes appear. Also in 0.18 some Avorion-events aren't reliable and thus break the mod.

All of these work with 0.17 and 0.18

I updated this one for beta 0.18 and 0.17

Edit: this should be sticky
« Last Edit: July 12, 2018, 11:14:15 AM by Laserzwei »



Devious

  • Hero Member
  • *****
  • Status:
    Offline
    Posts:
    579
  • Have you seen Rusty?
    • View Profile
    • Rusty's Universe and Community
Nothing significant changed this patch that isn't easily solved by a compare and merge of the files.
90% of the listed mods are inside our modpack, none gave a conflict when updating to beta 18.



Hammelpilaw

  • Sr. Member
  • ****
  • Status:
    Offline
    Posts:
    494
    • View Profile
    • Scrap Yard - Avofactory
All my mods listed in this topic are compatible with current Avorion stable and beta. The only "issue" with the Guardian Scout is, that it removes the Xsotan damage scaling near core. Watch mods topic for more information, I could use some help (ideas) there regarding the damage scaling.
@devs: Sticky please  :)
Scrap Yard Galaxy
My mods and tools

If you find an bug in my mods please contact me. My GitLab Account



Shrooblord

  • Hero Member
  • *****
  • Status:
    Offline
    Posts:
    523
    • View Profile
Nothing significant changed this patch that isn't easily solved by a compare and merge of the files.
90% of the listed mods are inside our modpack, none gave a conflict when updating to beta 18.
Could you be more specific? A list of names would be excellent. Do all of the mods still function correctly in-game?

----

Hammelpilaw, thanks for the info! Updating the list now.
Shrooblord



UnseenOni

  • Newbie
  • *
  • Status:
    Offline
    Posts:
    3
    • View Profile
Did a swap to 18 last week with several mods and I can list which ones worked and which didnt. Mind you it took me a while to get everything ported over but here's the list I had with respect to the untested mods:

Better mining AI is stable for 17 and  18
Better ship systems stable for both 17 and 18
MineCorp was a total unknown, I'm not even sure I had it installed correctly but it does work on 17, my players are all finding the mines and receiving the resources. (I recommend manual merging since overwriting can break game code)
Command package 100% works on 17, did not generate any problems on 18
Not enough turrets is stable on 17 and  was working on 18
Civil turret and fighter range definitely still works on 17 have not tested with 18 (with somed edits, I recommend manually merging to avoid breaking current game code)
Universal system works for both 17 and 18


I realize I'm a total nobody as far as the forums are concerned, and I'm relatively new to Avorion, but I've been modding games for almost a decade, I carefully merged at least 15 mods together off the forums, even some of the older ones, and they all work together for B17.






Shrooblord

  • Hero Member
  • *****
  • Status:
    Offline
    Posts:
    523
    • View Profile
Thank you for your work!

Mind you it took me a while to get everything ported over
As in, you had to manually make the mods compatible with 0.18? I think I should file those under "incompatible";  given that people would be looking to a thread like this wondering "can I install this to my version of the game just like that?", it would be misleading to tell them it's "Compatible*" with the asterisk being they have to power through some code to get it to work.

With that in mind, could you review your list and tell us which mods on it are indeed 100% compatible out-of-the-box and which need to be updated to be compatible with 0.18?

Quote
MineCorp was a total unknown, I'm not even sure I had it installed correctly but it does work on 17, my players are all finding the mines and receiving the resources. (I recommend manual merging since overwriting can break game code)
What does this mean - "total unknown"? But if I read this correctly, MineCorp works correctly on 0.17, if you install it properly. How about 0.18?

Quote
Civil turret and fighter range definitely still works on 17 have not tested with 18 (with somed edits, I recommend manually merging to avoid breaking current game code)
What are these edits? Can you / did you post them in the mod's thread, so other people know what to do to make it compatible, too?

Quote
I carefully merged at least 15 mods together off the forums, even some of the older ones, and they all work together for B17.
When you say merged, what do you mean? You mean integrating the 15 mods into the game code i.e. installing them, resolving conflicts manually where necessary, correct? B17 - Beta Branch 0.17? How about 0.18?

Again, thank you very much for your work. Just asking additional clarifications.

Quote
I realize I'm a total nobody as far as the forums are concerned, and I'm relatively new to Avorion
Oh? Well, welcome, then! Good to have you on-board. ;)

Quote
but I've been modding games for almost a decade
DEFINITELY GOOD TO HAVE YOU ON-BOARD. Come here and look at this blueprint I've got here... what do you think of...
Shrooblord



Delerium76

  • Newbie
  • *
  • Status:
    Offline
    Posts:
    4
    • View Profile
Played with System Control for a bit on 0.17.1.  It works, albeit there are some annoyances to the mod:

1. It uses alt+1 to alt+5 (unconfigurable keybinds) to switch between system sets, which has the happy side effect of also toggling your weapons on and off as well as re-centering your ship every time you use it.  Only solution is to either deal with it and keep adjusting every time, or change the game's default keybinds since you can't change the mod's keybinds.

2. There is no keybind (that I could find) to open the configuration menu to assign your current system set to a keybind.  A minor annoyance, but oh well.

3. As listed on their page, when you use a hotkey to switch systems, the systems currently installed will no longer show up on the vanilla ship systems menu.  This wouldn't be so bad except when combined with number 2 makes it frustrating to look at what you currently have equipped, and impossible to just swap out one or two systems of an existing set without clearing the whole thing and building it from scratch.

Nothing here game breaking or what I would necessarily call a bug, so I'd probably classify it as stable with room for improvement.



Seloune

  • Newbie
  • *
  • Status:
    Offline
    Posts:
    1
    • View Profile
Thanks you very much for this great topic very useful  ;)

It's sad to see so many good mods not compatible or abandoned in just one year.



Delerium76

  • Newbie
  • *
  • Status:
    Offline
    Posts:
    4
    • View Profile
Thanks you very much for this great topic very useful  ;)

It's sad to see so many good mods not compatible or abandoned in just one year.
there's only a few in that list that are not compatible.  Most are just unknown.  Try a few out from the unknown list and report back.  That way the list can grow



Shrooblord

  • Hero Member
  • *****
  • Status:
    Offline
    Posts:
    523
    • View Profile
Thanks you very much for this great topic very useful  ;)

It's sad to see so many good mods not compatible or abandoned in just one year.
there's only a few in that list that are not compatible.  Most are just unknown.  Try a few out from the unknown list and report back.  That way the list can grow
This! Most of the mods in the "Stability Unknown" list have simply not been tested (extensively) yet. I'll get to them all sooner or later, but first, life calls me for other duties and responsibilities!

Only the mods listed under "Deprecated" are known to be incompatible with current versions of the game, and it is noted what the last-known stable version of the game was they still worked under.

Happy modding!
Shrooblord



TenshiRyu

  • Newbie
  • *
  • Status:
    Offline
    Posts:
    2
    • View Profile
Weapon Engineering (Turret Editor) - by darkconsole

I have this one working on the Beta branch without any problems!



Shrooblord

  • Hero Member
  • *****
  • Status:
    Offline
    Posts:
    523
    • View Profile
Thanks, list updated! Also thank you for the sticky, kind moderator. Your appreciation for this thread means a lot to me. <3
Shrooblord



Rinart73

  • Sr. Member
  • ****
  • Status:
    Offline
    Posts:
    264
  • Discord: Rinart73#7304
    • View Profile
My mod TransferCargoTweaks was updated to 0.17.1+, so please add it to the list