Author Topic: Crashing at game launch, singleplayer  (Read 240 times)

TwinMinds

  • Newbie
  • *
  • Status:
    Offline
    Posts:
    2
    • View Profile
on: January 06, 2019, 02:50:38 AM
Hello!

I just bought the game on steam and found it won't launch at all.  I click the launch button, and I'm immediately greeted with "we detected a game crash" and the game attempts to relaunch with low graphics settings.  I get a blank white game box briefly then it just disappears without anything else happening.

Attached is the latest game log.

I have the following system:
Intel i7-5820K CPU @ 3.30GHz
Nvidia Geforce 1080 TI (latest drivers as of yesterday, version 417.35)
32 GB DDR4 Ram

I am able to launch the server successfully with the server.bat file, but the game itself won't launch.  I have attempted to search for similar issues and I stumbled on the idea that the shaders were causing issues.  So I followed one of the fixes that worked for others, by changing the noise.frag file to return 0.0 for both noise functions.  That did not resolve the issue however.



cepheni

  • Developer
  • *
  • Status:
    Offline
    Posts:
    341
    • View Profile
on: January 08, 2019, 11:00:47 AM
Your GPU should indeed be perfectly able to play the game and I'm not sure what causes this.
Have you made sure to add both Avorion and AvorionServer to your exception list for the antivirus / firewall?  Do you have the possiblity to set Avorion as a game? Avorion is using OpenGL that many drivers don't detect as game and try to conserve energy by not running at full capacity.

I'll still look for more options for you, but it'd be awesome if you could try these things first :)



TwinMinds

  • Newbie
  • *
  • Status:
    Offline
    Posts:
    2
    • View Profile
on: January 12, 2019, 04:29:10 PM
Thank you for the suggestions, unfortunately I'm still in the same situation.  I have disabled antivirus entirely when trying to run the game, I verified Avorion and AvorionServer were both allowed through the firewall.  I also confirmed that nvidia drivers automatically recognized Avorion, and even tried to manually force it to run OpenGL under the 1080ti card.  No luck sadly.  Is there any other detail from a log somewhere I could grab to help troubleshoot?

I have also tried reinstalling the game entirely, but got the same results.