Author Topic: [Server][Crash]something went wrong when moving torpedoes out of shaft in resize  (Read 142 times)

RenokK

  • Newbie
  • *
  • Status:
    Offline
    Posts:
    1
    • View Profile
Hello and thank you for reading this.

I'm hosting a Server for a friend of mine and me to play together.
Today, after my friend jumped to a different sector the Server crashed, reporting:

An exception occurred: something went wrong when moving torpedoes out of shaft in resize


ServerOS:
- Ubuntu Server 16.04.2
Main Specs (not sure if important)
- CPU: Intel(R) Xeon(R) CPU E5-2640 v3 @ 2.60GHz 4 Cores
- RAM: 6GB

Server Log at the time of the crash:
https://pastebin.com/0jvdSxQq


We tried a few things so far, without any success.
- The stupid thing: Have you tried turning it off and on again
- Removed his player data
- Removed sector data to re-generate the sector
- combination of both

His ship is an alliance ship, not sure if that has anything to do with the issue.
I also tried sending his ship out of the sector, but it has no captain on it and I wasn't able to find any command to remotely give crew members to a ship.

I hope someone can help us get our ship back.

Also tried looking up the issue first. The only post I found, having the same error, was from mid 2018 and never got a response on here.
https://www.avorion.net/forum/index.php/topic,4894.msg26725.html#msg26725

Thank you for your help, I hope you are all having a wonderful day.
« Last Edit: February 26, 2019, 11:02:12 PM by RenokK »
and with strange aeons even death may die



cepheni

  • Developer
  • *
  • Status:
    Offline
    Posts:
    335
    • View Profile
I'm honestly not sure what you can do to get your ship back. It might well be that you had bad luck, and the ship is lost. Thankfully the game doesn't crash too often anymore.
You could try and use teleport, but I don't know if that works after you deleted the player data.