Author Topic: Crash on loading  (Read 266 times)

Morphikon

  • Newbie
  • *
  • Status:
    Offline
    Posts:
    3
    • View Profile
on: April 06, 2019, 04:15:50 AM
Hi Guys,

Have tried all the usual fixes for crashing on startup, updated drivers, repaired steam files, changed up to beta and back. All give me the white screen then crash to desktop.

Here is the log:

2019-04-06 12-09-06| Main Thread ID: 1
2019-04-06 12-09-06| Client started: "D:\Steam\steamapps\common\Avorion\bin\Avorion.exe" "--serverpath=bin/AvorionServer.exe"
2019-04-06 12-09-06| Enabled Traces:
2019-04-06 12-09-06| Client Beta 0.21.3 r14826 8781a5b2a144, running on Windows 10.
2019-04-06 12-09-06| CPU: Intel(R) Core(TM) i7-8700K CPU @ 3.70GHz 12 Cores
2019-04-06 12-09-06| RAM: 32GB
2019-04-06 12-09-06| Init Steamworks...Installed Steam exception handler
2019-04-06 12-09-06| Init Steamworks...Steam Branch: beta
2019-04-06 12-09-06|  ok
2019-04-06 12-09-06| Init Steamworks ok
2019-04-06 12-09-06| Init SDL2... ok
2019-04-06 12-09-06| SDL version (compiled): 2.0.3
2019-04-06 12-09-06| SDL version (linked): 2.0.3
2019-04-06 12-09-06| Getting display mode... ok
2019-04-06 12-09-06| Current display mode: 3440 x 1440
2019-04-06 12-09-06| Creating settings... loading...We detected a crash during game startup.
2019-04-06 12-09-06| Please make sure that you use the latest drivers for your graphics card.
2019-04-06 12-09-06| In an attempt to fix this problem, the graphics settings were reduced to an absolute minimum.
2019-04-06 12-09-07|  setting language... ok
2019-04-06 12-09-07| Creating client window...Creating window ...
2019-04-06 12-09-07| Detected 1 displays
2019-04-06 12-09-07| Display 0: x: 0, y: 0, w: 3440, h: 1440
2019-04-06 12-09-07| Using display 0
2019-04-06 12-09-07| Trying to create OpenGL 4.0 core window ...
2019-04-06 12-09-07| Creating window, x: 0, y: 0, w: 1280, h: 720... ok
2019-04-06 12-09-08| Creating GL context... ok
2019-04-06 12-09-08| Initializing GLEW... ok
2019-04-06 12-09-08| Setting display mode 1280 x 720 (Windowed)... ok
2019-04-06 12-09-08| GetDrawableSize: 1280 720
2019-04-06 12-09-08| GetWindowSize: 1280 720
2019-04-06 12-09-08| Creating client window ok
2019-04-06 12-09-08| Init rendering... starting rendering... initialize...OpenGL Context Information:
2019-04-06 12-09-08| Version: 4.0
2019-04-06 12-09-08| VersionString: 4.0.0 NVIDIA 419.67
2019-04-06 12-09-08| Vendor: NVIDIA Corporation
2019-04-06 12-09-08| Renderer: GeForce GTX 1070 Ti/PCIe/SSE2
2019-04-06 12-09-08| GLSL Version: 4.00 NVIDIA via Cg compiler
2019-04-06 12-09-08| GL_MAX_CUBE_MAP_TEXTURE_SIZE: 32768
2019-04-06 12-09-08| GL_MAX_ELEMENTS_INDICES: 1048576
2019-04-06 12-09-08| GL_MAX_ELEMENTS_VERTICES: 1048576
2019-04-06 12-09-08| GL_MAX_RENDERBUFFER_SIZE: 32768
2019-04-06 12-09-08| GL_MAX_TEXTURE_SIZE: 32768
2019-04-06 12-09-08| GL_MAX_VERTEX_ATTRIBS: 16
2019-04-06 12-09-08| GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS: 32
2019-04-06 12-09-08| Init Debug Message Callback... ok
2019-04-06 12-09-08| Set VSync... ok
2019-04-06 12-09-08| Secure BackBuffer... ok
2019-04-06 12-09-08| Init Canvas...Create canvas of size 640 x 360... ok
2019-04-06 12-09-08| Init Canvas ok
2019-04-06 12-09-08| Init UI Texture... ok
2019-04-06 12-09-08| Init Refraction Texture... ok
2019-04-06 12-09-08| Init Post Processing... ok
2019-04-06 12-09-08| Init Debug Renderers... ok
2019-04-06 12-09-08| DepthTexturesSupported: yes
2019-04-06 12-09-08| IntVertexAttributesSupported: yes
2019-04-06 12-09-08| DeferredSupported: yes
2019-04-06 12-09-08| LowSpecGPUDetected: no
2019-04-06 12-09-08| Available video memory: 6.60742 GB
2019-04-06 12-09-08| Rendering initialized
2019-04-06 12-09-08| Init rendering ok
2019-04-06 12-09-08| Check problematic drivers... ok
2019-04-06 12-09-08| Init shader level... ok
2019-04-06 12-09-08| Init loading screen...Starting thread [LoadingScreen Plan]...
2019-04-06 12-09-08| Started thread [LoadingScreen Plan] with id 2
2019-04-06 12-09-08|  ok
2019-04-06 12-09-08| Draw first loading screen... draw...Entered exception handler
2019-04-06 12-09-08| Thread 1 Error: EXCEPTION_ACCESS_VIOLATION
2019-04-06 12-09-08| Global ProfilerSection [1]:
2019-04-06 12-09-08| Thread Name [2]: LoadingScreen Plan
2019-04-06 12-09-08| RAM: 32
2019-04-06 12-09-08| CPU: Intel(R) Core(TM) i7-8700K CPU @ 3.70GHz 12 Cores
2019-04-06 12-09-08| CurrentScript [1]:
2019-04-06 12-09-08| GameVersionHash: 8781a5b2a144
2019-04-06 12-09-08| GameVersion: Beta 0.21.3 r14826 8781a5b2a144
2019-04-06 12-09-08| GL Version: 4.0
2019-04-06 12-09-08| GL Version String: 4.0.0 NVIDIA 419.67
2019-04-06 12-09-08| GPU Vendor: NVIDIA Corporation
2019-04-06 12-09-08| GLSL Version: 4.00 NVIDIA via Cg compiler
2019-04-06 12-09-08| GPU Renderer: GeForce GTX 1070 Ti/PCIe/SSE2
2019-04-06 12-09-08| CurrentFunction [1]:
2019-04-06 12-09-08| === STACKTRACE =====================================
2019-04-06 12-09-08| #1: [ext] ?? [0x7ffa23d20a0a]
2019-04-06 12-09-08| #2: [ext] SwapBuffers [0x7ffb23b54f6e]
2019-04-06 12-09-08| #3: ?? [0xcb93ae]
2019-04-06 12-09-08| #4: ?? [0x40e082]
2019-04-06 12-09-08| #5: ?? [0x403c4b]
2019-04-06 12-09-08| #6: Mix_SetPanning [0x14b9d15]
2019-04-06 12-09-08| #7: ?? [0x4013f8]
2019-04-06 12-09-08| #8: ?? [0x4014eb]
2019-04-06 12-09-08| #9: [ext] BaseThreadInitThunk [0x7ffb273081f4]
2019-04-06 12-09-08| #10: [ext] RtlUserThreadStart [0x7ffb2781a251]
2019-04-06 12-09-08| ===================================================
2019-04-06 12-09-08| Sending crash report ...
2019-04-06 12-09-09| Crash report sent successfully!



Morphikon

  • Newbie
  • *
  • Status:
    Offline
    Posts:
    3
    • View Profile
on: April 07, 2019, 12:48:41 PM
Nobody? :(



Morphikon

  • Newbie
  • *
  • Status:
    Offline
    Posts:
    3
    • View Profile
on: April 08, 2019, 02:38:50 AM
Ok found a solution to this issue.

Using the -t all launch options i was able to get a slightly different error which led to a minecraft support forum of all things. Someone had said that if they had a certain piece of software running it would cause that error.

So i closed all game launchers except for steam and all other programs except for discord and that allowed me to start normally.

So i am going to assume that one of the game launchers was locking opengl somehow.

So good to be back in the game now though! :)



cepheni

  • Developer
  • *
  • Status:
    Offline
    Posts:
    363
    • View Profile
on: April 08, 2019, 05:21:56 PM
Good catch on that! Could you tell us which launchers where causing the issue?