Author Topic: Home sector completely empty after server crash  (Read 61 times)

Roderik

  • Newbie
  • *
  • Status:
    Offline
    Posts:
    3
    • View Profile
on: August 22, 2019, 06:15:42 PM
Hello,

Just discovered Avorion and already pretty addicted.! good job!

So I rent a server on G-Portal. It ran fine until now, but yesterday it froze when I attempted to jump into a system I previously visited, without problems. Restarted the server, logged in again and found my self in the drone, next to my ship. I could enter and fly around, but every time I tried to jump somewhere, the game froze again. Another player could play fine, as long as I did not join and froze the server again. (He did not try to visit the buggy sectors though.)
I downloaded the Galaxy and could play it locally, but with some bugs:
1 . The system I originally jumped to was completely empty. Used to be the home sector of a faction with lots of stations.
2.  Another system I visited earlier, which contained pirates , when I visited again the game made all the Pirate ships into my alliance ships.
3. All my factions relations where gone.
4. Some other sectors where empty, too.

I could solve the problem with the empty systems, by deleting the corresponding files in the /sectors subfolder.
So I uploaded the player files of my local copy and deleted the /sectors subfolder of the server, and everything ran fine again.

 Except: The home system is still empty. That´s a problem because this where I will spawn when I die - and there is no shipyard anymore. I tried to restore the original /sectors/35_448 files, but it did not help.  Would be great if we could restore the home sector to a functional state, as we put a lot of hours in already!

We are running the current stable 0.25.2 version.

Your client and server log:
Client Log: https://pastebin.com/Qabsir09
Server Log: https://pastebin.com/37eGEg8J


Your system specs:
Server on G-Portal says:
Core(TM) i7-3770K CPU @ 3.50GHz 8 Cores RAM: 31GB name: DJ_Avorion seed: XxI81wDM5z

Home system:
AMD 2700X and RTX2070, 32GB Ram

I´d really appreciate your help. If you need further info or files from the backup immediately after crash, let me know!

BR,
Daniel
« Last Edit: August 22, 2019, 06:32:10 PM by Roderik »



Roderik

  • Newbie
  • *
  • Status:
    Offline
    Posts:
    3
    • View Profile
on: August 24, 2019, 03:56:03 PM
Got it sorted, finally.

I used the backup-ed files from after the crash and deleted all the sector files with the newest timestamps (all I had ships in), except  the one with my home sector address (where I also had a ship, and also had the newest timestamp).

That seems to have solved the Problem.

Deleting only the to and from sectors from the jump that caused the crash was not enough .