Author Topic: Independents turret not shooting?  (Read 158 times)

Salminar

  • Jr. Member
  • **
  • Status:
    Offline
    Posts:
    94
    • View Profile
on: December 09, 2019, 07:26:20 PM
Hi.

Returning to the game to see how things are going and to my surprise, my ships that were mining, trading or salvaging do not use anymore their defensive turrets when they are attacked. It's strange cause in older versions of the game i'm pretty sure i had some "field salvagers" going into battle to recycle wrecks while their turrets were shooting at enemies. But now they simply sit around without fighting back.

The point defense still attack torps on the other hand.
Is it something wrong with my game or it's something intended and why?



gorgofdoom

  • Newbie
  • *
  • Status:
    Offline
    Posts:
    3
    • View Profile
on: February 15, 2020, 12:24:03 AM
Hmm.

 I'll offer that, in my experience, when you have a ship equipped with both weapons & salvage lasers they always use both on the wreckage that is targeted. Because this is appears wasteful, I only ever equip my salvage ships with the appropriate r-type salvage lasers.

Additionally, the AI captains in this game literally never defend themselves. If you have a craft set to defend another or patrol the sector, they'll attack enemies as a part of that function. If it is set to salvage, move, or simply has no orders at all they currently just sit and while being pummeled to death.

correct me if i am wrong, but this seems like a huge hole that needs to be fixed before "1.0".



FuryoftheStars

  • Full Member
  • ***
  • Status:
    Offline
    Posts:
    185
    • View Profile
on: February 15, 2020, 01:12:50 AM
I have not observed either behavior you both mention.

My salvagers with both weapon types will only use salvage lasers on wrecks and their combat weapons will fire on hostiles that get close enough.

I’d say you two are more experiencing bugs than actual game design that requires feedback.