Author Topic: Ship cast outside the sector boundry  (Read 44 times)

DextorPlays

  • Newbie
  • *
  • Status:
    Offline
    Posts:
    2
    • View Profile
on: January 13, 2020, 12:34:57 AM
I have a ship that glitched outside the sectors boundaries.  Game loads with normal UI but the space rendered is all grey with no locations available like stations.  After playing with the Player.dat files I was able to span myself in a drone at a shipyard.  Going to strategic view I can select my ship and it is listed as 1.65363e+015km away.  Well outside the sector edges.  If I try to teleport the ship to another sector the game hangs.  I can obviously rebuild the ship, but the old one will still be stuck on the galactic map.  Any way to teleport the ship to me or force a location change on the ship within a sector? 

Other things tried. 
Enter build to delete all the blocks and ship.  Ship does not render
Select the ship on the galactic map and order it to jump to another sector.  The ship never jumps.

Fixed:
Created copy of the Galaxies files in %appdata%
Deleted all Player_1.dat files in the Player folder
Restarted avorion to new game and shut down game
copied player_1.dat files back from backup
Deleted offending sector
Restarted Avorion (Offending sector recreated and I spawned in my drone at shipyard. Offending ship still on galaxy map.)
Command offending ship to jump to another sector
** Time passed as I played game **
Ship eventually jumps to other sector and is recoverable.

**Note: Some of these steps may not be required. I took out the big hammer and started whacking until it worked.
« Last Edit: January 13, 2020, 11:53:02 PM by DextorPlays »



unbekannt1984

  • Full Member
  • ***
  • Status:
    Offline
    Posts:
    183
    • View Profile
on: January 14, 2020, 02:41:42 PM
Hi,

I have had the same problem years ago. As far as I remember, I just needed to delete the Sector-File, since there is a "Backup" of your ships in the player-data, and restart Avorion.