Avorion Forum

Beta Branch => Beta Patch Notes => Topic started by: koonschi on March 01, 2018, 06:26:43 PM

Title: Beta Branch Patch 0.16.2 Patchnotes
Post by: koonschi on March 01, 2018, 06:26:43 PM
Patch 0.16.2

Date: March 1st, 2018

Beta Branch Note: These changes are currently available on the beta branch. The beta branch is for testing experimental changes and for finding and fixing errors.

This is how you get access to the beta branch (USE AT YOUR OWN RISK):
Right-Click on Avorion in your Steam list, Properties -> Betas -> Select branch 'beta'.

Balancing

"We had a few issues with PDCs being way stronger during the early game than intended, so we changed their damage type to the same as anti-fighter cannons, leaving their specialty of destroying torpedoes and fighters intact, but reducing the damage to everything else."
Graphics

"Improved visuals to better display torpedoes, so you know where they come or came from and what exactly hit you."
UI

"Mostly convenience things, and we also added a way to change the ingame difficulty without you having to edit .ini files."
Misc
Server
Bugfixes

"As always, user bug reports are marked with [UBR]. Thanks guys for reporting and helping us make the game better! Keep it up!"
Title: Re: Beta Branch Patch 0.16.2 Patchnotes
Post by: Ulrich_Rüstungjäger on March 01, 2018, 06:41:28 PM
"Persecutors no longer spawn in sectors with alliance or player ships that wouldn't trigger the spawn by themselves"

Happy days
Title: Re: Beta Branch Patch 0.16.2 Patchnotes
Post by: Ravien on March 01, 2018, 08:55:49 PM
Quote
Persecutors no longer spawn in sectors with alliance or player ships that wouldn't trigger the spawn by themselves

Thank you! This is a great change.
Title: Re: Beta Branch Patch 0.16.2 Patchnotes
Post by: Shirurthane on March 01, 2018, 09:04:52 PM
and i just build 20 pdc :D damn
Title: Re: Beta Branch Patch 0.16.2 Patchnotes
Post by: NoSvOrAx on March 01, 2018, 09:32:03 PM
and i just build 20 pdc :D damn

This only affects new PDCs
Title: Re: Beta Branch Patch 0.16.2 Patchnotes
Post by: Shirurthane on March 01, 2018, 09:52:41 PM
i know i want the new ones :D older is just cheating for me :P
Title: Re: Beta Branch Patch 0.16.2 Patchnotes
Post by: NoSvOrAx on March 02, 2018, 02:11:06 AM
Anyone know of anything in this update that would force a server wipe from the previous, other than getting rid of the OP PDC turrets?
Title: Re: Beta Branch Patch 0.16.2 Patchnotes
Post by: Kamo on March 02, 2018, 10:46:27 AM
The gamebreaking "no damage from weapons" bug is still here. Additional information: now even some collisions (especially glancing at high speeds) do no damage, but with/at some rare blocks or some time intervals damage registration happened.
I killed the pirates by crashing onto them, then got to another sector, where Xsotan attacked, same problem: they began by attacking a passing hauler that didn't go in an endless trail of explosions and dropped cargo.
Also, a screenshot of me firing at those Xsotan, they aren't even noticing I'm firing as they stay neutral ???.
(https://steamuserimages-a.akamaihd.net/ugc/927050999528029034/A8C46C7F419DE5531DE3118618D62B4E24D00428/) (https://steamuserimages-a.akamaihd.net/ugc/927050999528029034/A8C46C7F419DE5531DE3118618D62B4E24D00428/)
It feels that something is wrong between client and server, at either damage registration level or projectile management: projectiles are fired and hitting their targets on the client side, but at no effect on the server side :(.

Good debugging~
Title: Re: Beta Branch Patch 0.16.2 Patchnotes
Post by: koonschi on March 02, 2018, 11:54:28 AM
Quote
The gamebreaking "no damage from weapons" bug is still here. Additional information: now even some collisions (especially glancing at high speeds) do no damage, but with/at some rare blocks or some time intervals damage registration happened.
I killed the pirates by crashing onto them, then got to another sector, where Xsotan attacked, same problem: they began by attacking a passing hauler that didn't go in an endless trail of explosions and dropped cargo.
Also, a screenshot of me firing at those Xsotan, they aren't even noticing I'm firing as they stay neutral ???.

It feels that something is wrong between client and server, at either damage registration level or projectile management: projectiles are fired and hitting their targets on the client side, but at no effect on the server side :(.

Good debugging~

This seems like your server is having trouble keeping up. Can you enable profiling in your server.ini and then type /status into your chat window? The server will print out some information into files which you could then post here, so we can find out what's going wrong.

Edit: Also: Server Logs!
Title: Re: Beta Branch Patch 0.16.2 Patchnotes
Post by: Ulrich_Rüstungjäger on March 02, 2018, 04:38:42 PM
https://gyazo.com/429be1c4c64c208493d7951c757a7057 (https://gyazo.com/429be1c4c64c208493d7951c757a7057)

While it's not a server log, it does show what people are referring to.  I really don't think it is the server not being able to keep up, but rather something to do with the position of either the ship or the weapons themselves.  While the gif I posted doesn't show it I unloaded the entirety of both railguns onto the target until they overheated with no effect. I then moved around to the back of the target, fired and did damage.
Title: Re: Beta Branch Patch 0.16.2 Patchnotes
Post by: Meesmaalt on March 02, 2018, 06:04:44 PM
Ulrich means the old bug where wrecks or ships appear to be at one place but in reality they are slightly in different position, few hundred meters to few meters away form where they appear to be.

That bug appears most often when going to salvaging big wrecks. You need to fire in "air" where the wreck actually is for server/client to render/pos it into correct position.
Title: Re: Beta Branch Patch 0.16.2 Patchnotes
Post by: Kamo on March 02, 2018, 07:14:46 PM
I changed the profiling to true in the ini, then played a little (around a minute, prints the log), firing at my target until it was half health. Since it didn't move a lot as the authorities' ships surrounded it, more of my shots registered, like one in eight.
That server sure does a lot of saving. Joined both logs.

Quote from: Meesmaalt
Ulrich means the old bug where wrecks or ships appear to be at one place but in reality they are slightly in different position, few hundred meters to few meters away form where they appear to be.

That bug appears most often when going to salvaging big wrecks. You need to fire in "air" where the wreck actually is for server/client to render/pos it into correct position.
It reminded me of when I tried salvaging a station wreck, a few months before. Fired at it, didn't do damage, so I flied by and WHAM the wreck seemed to teleport into my ship and deal it a crippling blow ! Also once happened with asteroids (of course destroying my ship).

P.S.: Whoops, forgot the /status. Doing it again.
...Done it again, with another target and a collsion for good measure. Sending the profiling stats and other file by message... if I can do it.
Title: Re: Beta Branch Patch 0.16.2 Patchnotes
Post by: Ulrich_Rüstungjäger on March 03, 2018, 12:10:44 AM
The wreck was my only thing i hadto shoot at in that fame of time I had and there were no ships around that had the issue.
Title: Re: Beta Branch Patch 0.16.2 Patchnotes
Post by: koonschi on March 08, 2018, 02:59:24 PM
I looked at your logs and it looks like your machine is simply not able to handle all the updates of all the sectors you have stations in. If this problem is gone when you're starting a new game, then that's the cause.
Title: Re: Beta Branch Patch 0.16.2 Patchnotes
Post by: Kamo on March 09, 2018, 01:35:48 PM
The problem is effectively not happening in other galaxies, like my testbed which has less Out-Of-Sector-Production enabled sectors, where I got to a naonite sector and fought against torpedo-firing pirates which behaved normally under fire.
After all, my machine is right on the minimal requirements for the game, so it's a way of observing how Avorion fares with very limited resources.
So, it'd be a priority-based problem between In-Sector realtime gameplay and Out-of-Sector simulation, explaining why only some people have that problem: gaming rigs nowadays are more than ten times as powerful, so it would need ten times as much stations to observe the same-ish bug.

...d'oh, it kinda kills the whole "making a whole galactic empire" ambition of mine ::).

Maybe the simulation's update interval needs to be scaled with its available resources by simulated sector, or a server option to manually change the update interval.
I screwed around with the "emptySectorUpdateInterval", putting it to 5.0 then 30.0 from the default 0.5. Didn't do much.
Title: Re: Beta Branch Patch 0.16.2 Patchnotes
Post by: MoronicCinamun on March 11, 2018, 05:57:55 PM
Not sure if this is the place to post it because I'm not sure if it's a bug or not:
I just switched over my old save to the beta branch, apparently mining and salvaging lasers are now "armed", not unarmed turrets, and are taking up all my slots. Is this intended?
Title: Re: Beta Branch Patch 0.16.2 Patchnotes
Post by: Ravien on March 11, 2018, 08:17:04 PM
Not sure if this is the place to post it because I'm not sure if it's a bug or not:
I just switched over my old save to the beta branch, apparently mining and salvaging lasers are now "armed", not unarmed turrets, and are taking up all my slots. Is this intended?

Known bug.