Avorion Forum

General => Bugs => Topic started by: Kamo on April 08, 2018, 10:10:52 AM

Title: [0.16.7] "Seemingly random" crash
Post by: Kamo on April 08, 2018, 10:10:52 AM
...except I somehow reproduced the steps to crash, and it seems more related to a timed event than something else ? Now, when I log into my galaxy, it crashes my entire computer after 3-4 minutes of playing, resetting the galaxy to my previous save, unbinding all turrets and spawning me in a drone next to a station 6-7 km from my ship.
Now trying to connect then wait some more to see if the crash happens when doing nothing (else than reintegrating my ship)... Doesn't seem to crash now.
Jumped to another sector, browsed goods on a Mineral Extractor, and crashed roughly 20 seconds after browsing. Just before crashing a duplicate seemed to appear in the system where the Cocoa Farm was.
Also perused the logs: the crash always seems to happen some time after the "Entity index something has no script with index '2'" message.

Now trying jumping to another sector and doing nothing, with console open to see what happened. Also made a /status after jump, then some seconds later, then after using the nav console to prepare for a jump to a sector with the farm, then some seconds later and just before the crash ! I'll be sending a link shortly !
The crash seems related to some scripted event that happens once the sector is loaded and readied to go full-active :( (the time when the game finds the duplicate of my ship). Dubbed it the CocoCrash (https://soundcloud.com/nyonofficial/coco-crush).

And here's the link.
http://ti1ca.com/Album-Index2-CocoCrash-Pack-h4gzkdff (http://ti1ca.com/Album-Index2-CocoCrash-Pack-h4gzkdff)
It contains: all 5 client/server logs (with one occurence of being disconnected shortly after connecting) and the status files. Good bughunting :) !