Avorion Forum

General => News => Topic started by: koonschi on August 12, 2019, 03:17:19 PM

Title: Security Patch [Relevant for Modders]
Post by: koonschi on August 12, 2019, 03:17:19 PM
Date: August 12th, 2019

Hey guys,

We're doing a quick security patch today that also affects the Scripting API.

Scripting API

"We're adjusting the Server API privileges to the Client API privileges."

We still want mods to be able to communicate with external tools, of course. In order to make up for the lost functionality, we'll be adding a socket library in the near future.
Title: Re: Security Patch [Relevant for Modders]
Post by: Hammelpilaw on August 12, 2019, 04:43:49 PM
We still want mods to be able to communicate with external tools, of course. In order to make up for the lost functionality, we'll be adding a socket library in the near future.

Awesome. Do you already have any information about how this will work?
Title: Re: Security Patch [Relevant for Modders]
Post by: koonschi on August 12, 2019, 05:23:39 PM
We're probably going to use an established library like lua socket or something similar.