Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Daemon

Pages: [1] 2
1
Mods / Re: [MOD] AutoResearch Version 1.0
« on: September 11, 2017, 10:28:40 PM »
The "configs" folder does not usually exist, you can copy the zip file I created into your avorion folder, overwrite what it says and that should be it.

2
Mods / Re: [MOD][mOS] move Asteroids
« on: August 14, 2017, 07:31:35 PM »
I tried this yesterday and it works.
You are on a single player or multiplayer server?
The script is in both the client and server, in case it's the latter?
You have anything in the logs?

3
Suggestions / Re: Omicron Scaling and Overall Difficulty
« on: August 11, 2017, 01:50:49 PM »
I agree to the scaling up a point.
At some point bosses should "cap", otherwise progression would start to feel meaningless.

4
General Discussion / Re: Smarter companion ship AI?
« on: August 11, 2017, 01:49:09 PM »
I am actually going through the AI scripts these days to see if there is room for improvement. They are already moddable but I am unsure if the API provides enough options.
If anyone wants to dabble the scripts are in \data\scripts\entity\ai

5
Gameplay Discussion / Re: Increase loot collection range
« on: August 11, 2017, 01:45:23 PM »
Making force turrets pull things automatically could also be a cool idea :P

6
Mods / Re: [MOD] Havoc Mod Pack [ver: 0.12.7]
« on: August 11, 2017, 01:40:27 PM »
Were the turrets generated before you installed the mod? Could you take a screenshot of the tooltip?

7
Mods / Re: [MOD] Havoc Mod Pack [ver: 0.12.7]
« on: August 11, 2017, 10:55:25 AM »
Haven't seen that one happen and I've used the mod a fair bit.
Could it be just the game's tracking acting up?

8
Mods / Re: [MOD] Havoc Mod Pack [ver: 0.12.7]
« on: August 10, 2017, 09:55:33 PM »
No problem :)
Did you read my PM? :P

9
Mods / Re: [MOD] AutoResearch Version 1.0
« on: August 10, 2017, 07:48:15 PM »
Ok, I did quite a few changes now.
  • Moved the configuration to /configs/autoresearch for convenience
  • Added the option to enable/disable merging of turrets with different amounts of barrels
  • Added the option to disable research for specific tiers of weaponry/systems
  • Added the option to set a specific amount to use when researching a tier (ex: use 3 for common, 5 for legendary)

I am not quite happy with the code status but will work on it a bit more when I have more time :)

10
Mods / Re: [MOD] Havoc Mod Pack [ver: 0.12.7]
« on: August 10, 2017, 09:38:58 AM »
I think I found another problem, related to the xsotan artifacts.
Is it intentional to return this amount of turrets? Isn't it a bit too much?

11
Mods / Re: [MOD] Havoc Mod Pack [ver: 0.12.7]
« on: August 10, 2017, 09:06:44 AM »
Hello, this is just a quick edit but should work.

12
Troubleshooting / Re: Founding mines - Entity exists already
« on: August 08, 2017, 01:28:01 PM »
Do you have any mod? It seems like the script file is missing a function but I just checked the original avorion files and it's there:
function foundFactory(goodName, productionIndex)

13
Troubleshooting / Re: Server IP
« on: August 08, 2017, 01:22:45 PM »
Quote
I did all that, I am assuming had I not that my friends could not have connected at all.

Connecting via steam does not require port forwarding on the router. This seems like wrong port forwarding. Do they see the server as responsive in the direct connection menu?
There is also a quirk with the way that browser works, you need to add a server and restart the game for it to appear properly apparently.

14
Mods / Re: [MOD] Havoc Mod Pack [ver: 0.12.7]
« on: August 07, 2017, 09:22:50 PM »
It does not seem the crew feature works, when the crewboard.lua script is used the hire crew feature just does not work.

15
Multiplayer / Re: Little help with server? Worked for a bit, until...
« on: August 07, 2017, 11:34:59 AM »
Ok, simply put, Avorion bandwidth usage is absurd so running it on a normal home dsl is a no-go.
What kind of connection do you have?
What kind of issue are you having?
People cannot see the server at all?
People can see the server but not connect?

Pages: [1] 2